<!DOCTYPE html>
<html lang="en-US" class="html_boxed responsive av-preloader-disabled av-default-lightbox  html_header_top html_logo_center html_bottom_nav_header html_menu_right html_slim html_header_sticky html_header_shrinking html_header_topbar_active html_mobile_menu_phone html_disabled html_header_searchicon html_content_align_center html_header_unstick_top_disabled html_header_stretch html_entry_id_101428 ">
<head>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4620130499485229",
    enable_page_level_ads: true
  });
</script>
<meta charset="UTF-8" />
<meta name="robots" content="index, follow" />


<!-- mobile setting -->
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/365906230/BigBox_A', [300, 250], 'div-gpt-ad-1494449306601-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<!-- Scripts/CSS and wp_head hook -->
<title>Weekend Events: Holiday Events, Turkey Day Jam and More &#8211; CaryCitizen</title>
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=300;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='Weekend Events: Holiday Events, Turkey Day Jam and More';
</script>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="ByZypNwvXRj5Se6JiGq412ICWceAtK32gjW0ClwW5SM" />
<meta name="msvalidate.01" content="0B2C00BBB4F8DDF7CAABD981EF33905A" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Feed" href="http://carycitizen.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Comments Feed" href="http://carycitizen.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Weekend Events: Holiday Events, Turkey Day Jam and More Comments Feed" href="http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/feed/" />

<!-- google webfont font replacement -->
<link rel='stylesheet' id='avia-google-webfont' href='//fonts.googleapis.com/css?family=Nobile' type='text/css' media='all'/> 
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/carycitizen.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=0949d19e92070e135c4a4dc9a61e65ea"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='avia-grid-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/grid.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='avia-base-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/base.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='avia-layout-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/layout.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='avia-scs-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/shortcodes.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='avia-popup-css-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/js/aviapopup/magnific-popup.css?ver=1' type='text/css' media='screen' />
<link rel='stylesheet' id='avia-media-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/js/mediaelement/skin-1/mediaelementplayer.css?ver=1' type='text/css' media='screen' />
<link rel='stylesheet' id='avia-print-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/print.css?ver=1' type='text/css' media='print' />
<link rel='stylesheet' id='avia-dynamic-css'  href='http://carycitizen.com/wp-content/uploads/dynamic_avia/enfold.css?ver=5b857bb936825' type='text/css' media='all' />
<link rel='stylesheet' id='avia-custom-css'  href='http://carycitizen.com/wp-content/themes/enfold%203.8/css/custom.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=0949d19e92070e135c4a4dc9a61e65ea' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://carycitizen.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.7' type='text/css' media='all' />
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/themes/enfold%203.8/js/avia-compat.js?ver=2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.7'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.7'></script>
<link rel='https://api.w.org/' href='http://carycitizen.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://carycitizen.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://carycitizen.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The Hive, West Cary&#8217;s First Town Recreation Facility, Now Open' href='http://carycitizen.com/2018/11/13/the-hive-west-carys-first-town-recreation-facility-now-open/' />

<link rel="canonical" href="http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/" />
<link rel='shortlink' href='https://wp.me/p1Co7N-qnW' />
<link rel="alternate" type="application/json+oembed" href="http://carycitizen.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcarycitizen.com%2F2018%2F11%2F14%2Fweekend-events-holiday-events-turkey-day-jam-and-more%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://carycitizen.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcarycitizen.com%2F2018%2F11%2F14%2Fweekend-events-holiday-events-turkey-day-jam-and-more%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen RSS2 Feed" href="http://carycitizen.com/feed/" />
<link rel="pingback" href="http://carycitizen.com/xmlrpc.php" />
<!--[if lt IE 9]><script src="http://carycitizen.com/wp-content/themes/enfold%203.8/js/html5shiv.js"></script><![endif]-->
<link rel="icon" href="http://carycitizen.com/wp-content/uploads/2016/12/favicon.ico" type="image/x-icon">
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Weekend Events: Holiday Events, Turkey Day Jam and More" />
<meta property="og:url" content="http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/" />
<meta property="og:description" content="The weather may be dower this week so find some fun events to keep yourself warm around Cary this weekend. There are several big holiday events at shopping centers around town, plus the annual fund…" />
<meta property="article:published_time" content="2018-11-14T14:29:05+00:00" />
<meta property="article:modified_time" content="2018-11-14T14:04:27+00:00" />
<meta property="og:site_name" content="CaryCitizen" />
<meta property="og:image" content="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="550" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@CaryCitizen" />
<meta name="twitter:site" content="@CaryCitizen" />
<meta name="twitter:text:title" content="Weekend Events: Holiday Events, Turkey Day Jam and More" />
<meta name="twitter:image" content="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->


<!--
Debugging Info for Theme support: 

Theme: Enfold
Version: 3.8
Installed: enfold 3.8
AviaFramework Version: 4.6
AviaBuilder Version: 0.9.1
ML:256-PU:71-PLA:10
WP:4.9.8
Updates: disabled
-->

<style type='text/css'>
@font-face {font-family: 'entypo-fontello'; font-weight: normal; font-style: normal;
src: url('http://carycitizen.com/wp-content/themes/enfold%203.8/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?v=3');
src: url('http://carycitizen.com/wp-content/themes/enfold%203.8/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?v=3#iefix') format('embedded-opentype'), 
url('http://carycitizen.com/wp-content/themes/enfold%203.8/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff?v=3') format('woff'), 
url('http://carycitizen.com/wp-content/themes/enfold%203.8/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf?v=3') format('truetype'), 
url('http://carycitizen.com/wp-content/themes/enfold%203.8/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg?v=3#entypo-fontello') format('svg');
} #top .avia-font-entypo-fontello, body .avia-font-entypo-fontello, html body [data-av_iconfont='entypo-fontello']:before{ font-family: 'entypo-fontello'; }
</style>
</head>




<body id="top" class="post-template-default single single-post postid-101428 single-format-standard boxed nobile arial-websave _arial " itemscope="itemscope" itemtype="https://schema.org/WebPage" >

	
	<div id='wrap_all'>

	
<header id='header' class='all_colors header_color light_bg_color  av_header_top av_logo_center av_bottom_nav_header av_menu_right av_slim av_header_sticky av_header_shrinking av_header_stretch av_mobile_menu_phone av_header_searchicon av_header_unstick_top_disabled av_header_border_disabled'  role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader" >

<a id="advanced_menu_toggle" href="#" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></a><a id="advanced_menu_hide" href="#" 	aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></a>		<div id='header_meta' class='container_wrap container_wrap_meta  av_secondary_left av_extra_header_active av_entry_id_101428'>
		
			      <div class='container'>
			      <nav class='sub_menu'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><ul id="avia2-menu" class="menu"><li id="menu-item-10725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10725"><a href="http://carycitizen.com/subscribe/">Subscribe</a></li>
<li id="menu-item-24935" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24935"><a href="http://carycitizen.com/advertising/">Advertise</a></li>
<li id="menu-item-75889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-75889"><a href="http://carycitizen.com/policies-faqs/">Policies &#038; FAQs</a>
<ul class="sub-menu">
	<li id="menu-item-75891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75891"><a href="http://carycitizen.com/policies-faqs/submitting-stories/">Submitting Stories</a></li>
	<li id="menu-item-75892" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75892"><a href="http://carycitizen.com/policies-faqs/calendar-faq/">Calendar FAQ</a></li>
	<li id="menu-item-75893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75893"><a href="http://carycitizen.com/policies-faqs/comments-policy/">Comments Policy</a></li>
	<li id="menu-item-75890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75890"><a href="http://carycitizen.com/policies-faqs/usage-rights/">Usage &#038; Rights</a></li>
</ul>
</li>
<li id="menu-item-76065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-76065"><a href="http://carycitizen.com/business-services/">Business Services</a>
<ul class="sub-menu">
	<li id="menu-item-90006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90006"><a href="http://carycitizen.com/photography/">Photography</a></li>
	<li id="menu-item-90007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90007"><a href="http://carycitizen.com/websites/">Websites</a></li>
</ul>
</li>
<li id="menu-item-75925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75925"><a href="http://carycitizen.com/contributors/">Contributors</a></li>
<li id="menu-item-24939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24939"><a href="http://carycitizen.com/contact/">Contact</a></li>
<li id="menu-item-87835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87835"><a href="http://carycitizen.com/tag-cloud/">Tag Cloud</a></li>
</ul></nav>			      </div>
		</div>

		<div  id='header_main' class='container_wrap container_wrap_logo'>
	
        <div class='container av-logo-container'><div class='inner-container'><strong class='logo'><a href='http://carycitizen.com/'><img height='100' width='300' src='http://carycitizen.com/wp-content/uploads/2016/12/cc-logo-450.png' alt='CaryCitizen' /></a></strong></div></div><div id='header_main_alternate' class='container_wrap'><div class='container'><nav class='main_menu' data-selectname='Select a page'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><div class="avia-menu av-main-nav-wrap"><ul id="avia-menu" class="menu av-main-nav"><li id="menu-item-87807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-top-level menu-item-top-level-1"><a href="http://carycitizen.com/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Home</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-87726" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-top-level menu-item-top-level-2"><a href="http://carycitizen.com/category/featured/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Latest Stories</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-88650" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/news/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">News</span></a></li>
	<li id="menu-item-88651" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor"><a href="http://carycitizen.com/category/community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Community</span></a></li>
</ul>
</li>
<li id="menu-item-87718" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-top-level menu-item-top-level-3"><a href="http://carycitizen.com/category/community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Community</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-87920" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/agriculture-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Agriculture</span></a></li>
	<li id="menu-item-87727" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/education-community-2/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Education</span></a></li>
	<li id="menu-item-88653" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/business/downtown-business/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Downtown</span></a></li>
	<li id="menu-item-87719" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/environment/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Environment</span></a></li>
	<li id="menu-item-87720" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/gardening-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Gardening</span></a></li>
	<li id="menu-item-87728" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/news/government/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Government</span></a></li>
	<li id="menu-item-87803" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/health/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Health</span></a></li>
	<li id="menu-item-87721" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/history-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">History</span></a></li>
	<li id="menu-item-87722" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/money-matters/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Money Matters</span></a></li>
	<li id="menu-item-88652" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag"><a href="http://carycitizen.com/tag/morrisville/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Morrisville</span></a></li>
</ul>
</li>
<li id="menu-item-87717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-top-level menu-item-top-level-4"><a href="http://carycitizen.com/category/business/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Business</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-87740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-5"><a href="http://carycitizen.com/category/opinion/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Opinion</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-87744" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://carycitizen.com/author/bill-fletcher/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Bill Fletcher</span></a></li>
	<li id="menu-item-87742" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/opinion/dons-blog/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Don&#8217;s Blog</span></a></li>
	<li id="menu-item-87743" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/opinion/harolds-blog/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Harold&#8217;s Blog</span></a></li>
	<li id="menu-item-89388" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/opinion/loris-blog/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Lori&#8217;s Blog</span></a></li>
</ul>
</li>
<li id="menu-item-87723" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-top-level menu-item-top-level-6"><a href="http://carycitizen.com/category/community/events/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Events</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-87724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-7"><a href="http://carycitizen.com/category/community/food/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-87923" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/food/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food</span></a></li>
	<li id="menu-item-87725" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/food/recipes/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Recipes</span></a></li>
	<li id="menu-item-87731" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/community/restaurants-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Restaurants</span></a></li>
	<li id="menu-item-87732" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag"><a href="http://carycitizen.com/tag/supermarkets/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Markets</span></a></li>
</ul>
</li>
<li id="menu-item-87716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-top-level menu-item-top-level-8"><a href="http://carycitizen.com/category/arts-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Arts</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-87922" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/arts-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Arts</span></a></li>
	<li id="menu-item-87798" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/arts-community/dance-arts-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Dance</span></a></li>
	<li id="menu-item-87799" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/arts-community/film/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Movies</span></a></li>
	<li id="menu-item-87800" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/arts-community/music-arts/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Music</span></a></li>
	<li id="menu-item-87802" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/arts-community/photography-arts-community-2/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Photography</span></a></li>
</ul>
</li>
<li id="menu-item-87730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-mega-parent  menu-item-top-level menu-item-top-level-9"><a href="http://carycitizen.com/category/sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Sports</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-87891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-top-level menu-item-top-level-10"><a href="http://carycitizen.com/maps-guides/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Maps &#038; Guides</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-88644" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://carycitizen.com/category/guides/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Seasonal Guides</span></a></li>
	<li id="menu-item-92522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="http://foodcary.com" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food Cary</span></a>
	<ul class="sub-menu">
		<li id="menu-item-92523" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://foodcary.com/downtown-dining/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Downtown Dining Map</span></a></li>
		<li id="menu-item-92524" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://foodcary.com/supermarkets-map/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food Markets Map</span></a></li>
	</ul>
</li>
	<li id="menu-item-90165" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://carycitizen.com/maps-guides/downtown-map/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Downtown Printed Map</span></a></li>
	<li id="menu-item-87737" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://carycitizen.com/maps-guides/cary-parks/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Cary Parks Map</span></a></li>
	<li id="menu-item-87736" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://carycitizen.com/maps-guides/cary-nc-non-profits/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Cary Non-Profits Directory</span></a></li>
	<li id="menu-item-87829" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://carycitizen.com/maps-guides/worship-page/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Cary Worship Directory</span></a></li>
</ul>
</li>
<li id="menu-item-87733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-11"><a href="http://carycitizen.com/calendar/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Calendar</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-search" class="noMobile menu-item menu-item-search-dropdown menu-item-avia-special">
							<a href="?s=" data-avia-search-tooltip="

&lt;form action=&quot;http://carycitizen.com/&quot; id=&quot;searchform&quot; method=&quot;get&quot; class=&quot;&quot;&gt;
	&lt;div&gt;
		&lt;input type=&quot;submit&quot; value=&quot;&quot; id=&quot;searchsubmit&quot; class=&quot;button avia-font-entypo-fontello&quot; /&gt;
		&lt;input type=&quot;text&quot; id=&quot;s&quot; name=&quot;s&quot; value=&quot;&quot; placeholder='Search' /&gt;
			&lt;/div&gt;
&lt;/form&gt;" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Search</span></a>
	        		   </li></ul></div></nav></div> </div> 
		<!-- end container_wrap-->
		</div>
		
		<div class='header_bg'></div>

<!-- end header -->
</header>
		
	<div id='main' class='all_colors' data-scroll-offset='88'>

	
		<div class='container_wrap container_wrap_first main_color sidebar_right'>

			<div class='container template-blog template-single-blog '>

				<main class='content units av-content-small alpha  av-blog-meta-html-info-disabled'  role="main" itemscope="itemscope" itemtype="https://schema.org/Blog" >

<span align="center"><script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://goodtreecompany.com/advertising/www/delivery/ajs.php':'http://goodtreecompany.com/advertising/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=6");
   document.write ('&cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&exclude=" + document.MAX_used);
   document.write (document.charset ? '&charset='+document.charset : (document.characterSet ? '&charset='+document.characterSet : ''));
   document.write ("&loc=" + escape(window.location));
   if (document.referrer) document.write ("&referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://goodtreecompany.com/advertising/www/delivery/ck.php?n=a0c775d2&cb=334' target='_blank'><img src='http://goodtreecompany.com/advertising/www/delivery/avw.php?zoneid=6&cb=223&n=a0c775d2' border='0' alt='' /></a></noscript>
</span>

<br /><br />

                    <article class='post-entry post-entry-type-standard post-entry-101428 post-loop-1 post-parity-odd post-entry-last single-big with-slider post-101428 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-featured tag-events tag-weekend'  itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost" ><div class="big-preview single-big"><a href="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1.jpg" title="Weekend Events: Holiday Events, Turkey Day Jam and More"><img width="800" height="321" src="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-800x321.jpg" class="attachment-entry_with_sidebar size-entry_with_sidebar wp-post-image" alt="" /></a></div><div class='blog-meta'></div><div class='entry-content-wrapper clearfix standard-content'><header class="entry-content-header"><h1 class='post-title entry-title'  itemprop="headline" >	<a href='http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/' rel='bookmark' title='Permanent Link: Weekend Events: Holiday Events, Turkey Day Jam and More'>Weekend Events: Holiday Events, Turkey Day Jam and More			<span class='post-format-icon minor-meta'></span>	</a></h1><span class='post-meta-infos'><time class='date-container minor-meta updated' >November 14, 2018</time><span class='text-sep text-sep-date'>/</span><span class='comment-container minor-meta'><a href="http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/#respond" class="comments-link" >0 Comments</a></span><span class='text-sep text-sep-comment'>/</span><span class="blog-categories minor-meta">in <a href="http://carycitizen.com/category/community/events/" rel="tag">Events</a>, <a href="http://carycitizen.com/category/featured/" rel="tag">Featured</a> </span><span class="text-sep text-sep-cat">/</span><span class="blog-author minor-meta">by <span class="entry-author-link" ><span class="vcard author"><span class="fn"><a href="http://carycitizen.com/author/staff/" title="Posts by staff" rel="author">staff</a></span></span></span></span></span></header><div class="entry-content"  itemprop="text" ><p>Cary, NC – The weather may be dower this week so find some fun events to keep yourself warm around Cary this weekend. There are several big holiday events at shopping centers around town, plus the annual fundraiser Pre-Turkey Day Jam presented by Six String and much more.<span id="more-101428"></span></p>
<h3>To see a full list of Cary events, go to the <a href="http://carycitizen.com/calendar">CaryCitizen calendar</a>.</h3>
<h2>Thursday, November 15, 2018</h2>
<p><a href="http://thecarytheater.com/events/"><span style="text-decoration: underline;"><strong>The Cary Theater</strong></span></a> is playing new feature films and documentaries all this weekend. Starting on Thursday, you can see the aptly named coffee documentary &#8220;<a href="http://thecarytheater.com/event/a-film-about-coffee-2/">A Film About Coffee</a>&#8221; at 2 and 9:15 PM as well as the new drama &#8220;<a href="http://thecarytheater.com/event/the-wife-4/">The Wife</a>&#8221; at 7 PM.</p>
<p><a href="http://www.riadabyadair.com/christmas-countdown-sign-workshop-11-15/"><span style="text-decoration: underline;"><strong>Cute Buttons</strong></span></a> at Park West Village in Morrisville is holding a holiday craft workshop. This workshop will teach you to create a &#8220;Candy Cane Countdown to Christmas Calendar&#8221; and it starts at 6:30 PM.</p>
<p><a href="http://carync.iqm2.com/Citizens/Default.aspx"><span style="text-decoration: underline;"><strong>The Cary Town Council</strong></span></a> is having their regular meeting this Thursday at 6:30 PM at Cary Town Hall. These meetings are a good way to learn what&#8217;s going on around town and they are always free and open to the public.</p>
<p>To see more Thursday events, go to our <a href="http://carycitizen.com/calendar">calendar</a>.</p>
<p><a href="http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight.jpg"><img class="alignnone size-full wp-image-85107" src="http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight.jpg" alt="Cary Theater" width="800" height="568" srcset="http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight.jpg 800w, http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight-300x213.jpg 300w, http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight-768x545.jpg 768w, http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight-260x185.jpg 260w, http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight-705x501.jpg 705w, http://carycitizen.com/wp-content/uploads/2016/08/CaryTheaterNight-450x320.jpg 450w" sizes="(max-width: 800px) 100vw, 800px" /></a></p>
<h2>Friday, November 16, 2018</h2>
<p><a href="https://www.facebook.com/events/897859053738383/"><span style="text-decoration: underline;"><strong>Waverly Place</strong></span></a> holds its annual tree lighting ceremony this Friday with festivities and events starting at 5:30 PM, leading up to the tree lighting itself at 7 PM, conducted by Cary Mayor Harold Weinbrecht. Also, Frosty the Snowman and Rudolph the Red-Nosed Reindeer with be roving the shopping center.</p>
<p><strong><a href="https://www.parkwestvillage.net/event/winterwonderland/"><span style="text-decoration: underline;">Park West Village</span></a> </strong>in Morrisville is holding its Winter Wonderland event on Friday. Starting at 5:30 PM, there will be train rides, carolers, sledding slopes and story time with Santa. There will also be a tree lot where families can buy their Christmas tree. This event runs from Friday to Sunday.</p>
<p><a href="http://thecarytheater.com/event/pre-turkey-day-benefit-jam-presented-by-six-string/"><span style="text-decoration: underline;"><b>Six String</b></span></a> is holding their Pre-Turkey Day Benefit Jam at the Cary Theater, with local musicians and Cary Theater favorites performing including Jon Shain, FJ Ventre, Laurelyn Dossett and many more. All proceeds go to The Interfaith Council for Social Services and the Play It Forward Scholarship Fund. The concert starts at 8 PM.</p>
<p>There are more Friday events on our <a href="http://carycitizen.com/calendar">calendar</a>.</p>
<h2>Saturday, November 17, 2018</h2>
<p><a href="https://www.townofcary.org/recreation-enjoyment/facilities/senior-center"><span style="text-decoration: underline;"><strong>The Cary Senior Center</strong></span></a> is holding their annual craft show with arts and crafts made by Cary residents aged 50 and older for sale. Also enjoy coffee and other refreshments sold by the Cary Teen Council, all starting at 9 AM.</p>
<p><a href="http://bit.ly/2QOi2E4"><span style="text-decoration: underline;"><strong>Glenaire Retirement Community</strong></span></a> is holding their holiday craft fair this Saturday at 10 AM, and it&#8217;s an opportunity to buy handmade gifts from Wake County artists.</p>
<p><a href="http://thecarytheater.com/event/comedy-night-with-karen-mills-and-andy-forrester/"><span style="text-decoration: underline;"><strong>Comedians Karen Mill and Andy Forrester</strong></span></a> will perform at the Cary Theater this Saturday at 8 PM. Both are accomplished touring musicians.</p>
<p>You can find more Saturday events on our <a href="http://carycitizen.com/calendar">calendar</a>.</p>
<p><a href="http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1.jpg"><img class="alignnone size-full wp-image-101169" src="http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1.jpg" alt="Downtown Cary" width="1200" height="801" srcset="http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1.jpg 1200w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-300x200.jpg 300w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-768x513.jpg 768w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-1030x688.jpg 1030w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-705x471.jpg 705w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-450x300.jpg 450w, http://carycitizen.com/wp-content/uploads/2018/10/academy-chatham-downtown-cary-7096-1-560x374.jpg 560w" sizes="(max-width: 1200px) 100vw, 1200px" /></a></p>
<h2>Around the Triangle</h2>
<p>All this week, <a href="https://www.dukeenergycenterraleigh.com/events/jersey-boys"><span style="text-decoration: underline;"><strong>Memorial Auditorium</strong></span></a> in Downtown Raleigh will be hosting a performance of the musical &#8220;Jersey Boys.&#8221; It includes hit songs from the Four Seasons and tells the story of their rise and fall. Times differ from day to day with all times on the ticket website.</p>
<p><a href="https://www.goodnightscomedy.com/events/25902"><span style="text-decoration: underline;"><strong>Goodnights Comedy Club</strong></span></a> in Raleigh is hosting comedian Steve-O this Friday and Saturday. Steve-O made himself famous as one of the most popular daredevils on the TV show &#8220;Jackass.&#8221; Shows are at 7:30 and 10:30 PM both days.</p>
<p><a href="http://www.durhamartwalk.com"><span style="text-decoration: underline;"><strong>The Durham Art Walk Holiday Market</strong></span></a> is this Saturday and Sunday in the Downtown Durham Historic District. Admission is free and it&#8217;s a good way to find arts and crafts by local artisans for holiday presents, plus there will be food, drinks, live music and a kids&#8217; zone. It runs from 10 AM to 5 PM on Saturday and 1 to 5 PM on Sunday.</p>
<hr />
<p><em>Events from the <a href="http://carycitizen.com/calendar">CaryCitizen calendar</a>. Photos by Hal Goodtree and <a href="https://flic.kr/p/QeXVPo" target="_blank" rel="noopener">Antonio Castagna</a>.</em></p>
</div><footer class="entry-footer"><span class="blog-tags minor-meta"><strong>Tags:</strong><span> <a href="http://carycitizen.com/tag/events/" rel="tag">Events</a>, <a href="http://carycitizen.com/tag/weekend/" rel="tag">Weekend</a></span></span></footer><div class='post_delimiter'></div></div><div class='post_author_timeline'></div><span class='hidden'>
			<span class='av-structured-data'  itemscope="itemscope" itemtype="https://schema.org/ImageObject"  itemprop='image'>
					   <span itemprop='url' >http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1.jpg</span>
					   <span itemprop='height' >550</span>
					   <span itemprop='width' >800</span>
				  </span><span class='av-structured-data'  itemprop="publisher" itemtype="https://schema.org/Organization" itemscope="itemscope" >
				<span itemprop='name'>staff</span>
				<span itemprop='logo' itemscope itemtype='http://schema.org/ImageObject'>
				   <span itemprop='url'>http://carycitizen.com/wp-content/uploads/2016/12/cc-logo-450.png</span>
				 </span>
			  </span><span class='av-structured-data'  itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person" ><span itemprop='name'>staff</span></span><span class='av-structured-data'  itemprop="datePublished" datetime="2018-11-14T09:29:05+00:00" >2018-11-14 09:29:05</span><span class='av-structured-data'  itemprop="dateModified" itemtype="https://schema.org/dateModified" >2018-11-14 09:04:27</span><span class='av-structured-data'  itemprop="mainEntityOfPage" itemtype="https://schema.org/mainEntityOfPage" ><span itemprop='name'>Weekend Events: Holiday Events, Turkey Day Jam and More</span></span></span></article><div class='single-big'></div>
<p><em>First time commenter? Please read our <a href="http://carycitizen.com/policies-faqs/comments-policy/" target="_self">Comments Policy</a>. Comments are at the discretion of the Publisher.</em></p>
<br />


	        	
	        	
<div class='comment-entry post-entry'>

<div class='comment_meta_container'>
			
			<div class='side-container-comment'>
	        		
	        		<div class='side-container-comment-inner'>
	        				        			
	        			<span class='comment-count'>0</span>
   						<span class='comment-text'>replies</span>
   						<span class='center-border center-border-left'></span>
   						<span class='center-border center-border-right'></span>
   						
	        		</div>
	        		
	        	</div>
			
			</div>

<div class='comment_container'><h3 class='miniheading'>Leave a Reply</h3><span class='minitext'>Want to join the discussion? <br/>Feel free to contribute!</span>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://carycitizen.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='101428' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9358676353" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="178"/></p>			</form>
			</div><!-- #respond -->
	</div>
</div>
				<!--end content-->

				</main>

				<aside class='sidebar sidebar_right smartphones_sidebar_active alpha units'  role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar" ><div class='inner_sidebar extralight-border'><section id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://goodtreecompany.com/advertising/www/delivery/ajs.php':'https://goodtreecompany.com/advertising/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=2");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://goodtreecompany.com/advertising/www/delivery/ck.php?n=a05bec9c&amp;cb=1341' target='_blank'><img src='https://goodtreecompany.com/advertising/www/delivery/avw.php?zoneid=2&amp;cb=121&amp;n=a05bec9c' border='0' alt='' /></a></noscript></div><span class="seperator extralight-border"></span></section><section id="text-26" class="widget clearfix widget_text"><h3 class="widgettitle">CONNECT WITH CARYCITIZEN</h3>			<div class="textwidget"><a href="http://eepurl.com/SCpj1" target="_blank" style="color:gray">Subscribe</a>  |  <a href="http://www.twitter.com/carycitizen" target="_blank" style="color:gray">Twitter</style></a>  |  <a href="http://www.facebook.com/pages/CaryCitizen/124390674088" target="_blank" style="color:gray">Facebook</a></div>
		<span class="seperator extralight-border"></span></section><section id="custom_html-5" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://goodtreecompany.com/advertising/www/delivery/ajs.php':'https://goodtreecompany.com/advertising/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=3");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='https://goodtreecompany.com/advertising/www/delivery/ck.php?n=a331b9f1&amp;cb=2202' target='_blank'><img src='https://goodtreecompany.com/advertising/www/delivery/avw.php?zoneid=3&amp;cb=2012&amp;n=a331b9f1' border='0' alt='' /></a></noscript></div><span class="seperator extralight-border"></span></section><section id="recent-comments-3" class="widget clearfix widget_recent_comments"><h3 class="widgettitle">Latest Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Gary</span> on <a href="http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/#comment-39134">Harold&#8217;s Blog: The Hive, Cary Band Day and More</a></li><li class="recentcomments"><span class="comment-author-link">Robert Bush</span> on <a href="http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/#comment-39121">Harold&#8217;s Blog: The Hive, Cary Band Day and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary</span> on <a href="http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/#comment-39068">Harold&#8217;s Blog: The Hive, Cary Band Day and More</a></li><li class="recentcomments"><span class="comment-author-link">Michael Papich</span> on <a href="http://carycitizen.com/2018/11/08/winter-and-holiday-events-for-cary-2018/#comment-39064">Winter and Holiday Events for Cary 2018</a></li><li class="recentcomments"><span class="comment-author-link">John L Cheney</span> on <a href="http://carycitizen.com/2018/11/08/winter-and-holiday-events-for-cary-2018/#comment-39060">Winter and Holiday Events for Cary 2018</a></li><li class="recentcomments"><span class="comment-author-link">Lindsey Chester</span> on <a href="http://carycitizen.com/2018/11/08/samaritans-corner-the-easel-of-jesus/#comment-39036">Samaritan&#8217;s Corner: The Easel of Jesus</a></li><li class="recentcomments"><span class="comment-author-link">Hal Goodtree</span> on <a href="http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/#comment-39011">Harold&#8217;s Blog: The Hive, Cary Band Day and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary</span> on <a href="http://carycitizen.com/2018/11/07/weekend-events-diamante-awards-food-and-flea-and-more/#comment-39009">Weekend Events: Diamante Awards, Food and Flea and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary</span> on <a href="http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/#comment-38993">Harold&#8217;s Blog: The Hive, Cary Band Day and More</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://27513' rel='external nofollow' class='url'>Robert</a></span> on <a href="http://carycitizen.com/2018/10/30/samaritans-corner-reunion-over-me/#comment-38990">Samaritan&#8217;s Corner: Reunion Over Me</a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-2" class="widget clearfix newsbox"><h3 class="widgettitle">Latest News</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Weekend Events: Holiday Events, Turkey Day Jam and More' href='http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Weekend Events: Holiday Events, Turkey Day Jam and More<span class='news-time'>November 14, 2018 - 9:29 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='The Hive, West Cary&#8217;s First Town Recreation Facility, Now Open' href='http://carycitizen.com/2018/11/13/the-hive-west-carys-first-town-recreation-facility-now-open/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/Hive1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="The Hive" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Hive1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>The Hive, West Cary&#8217;s First Town Recreation Facility, Now Open<span class='news-time'>November 13, 2018 - 11:30 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Canes Have Comeback 3-2 OT Win Against Ward and Blackhawks' href='http://carycitizen.com/2018/11/13/canes-have-comeback-3-2-ot-win-against-ward-and-blackhawks/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Carolina Hurricanes" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes Have Comeback 3-2 OT Win Against Ward and Blackhawks<span class='news-time'>November 13, 2018 - 9:31 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Harold&#8217;s Blog: Election Day, Veterans&#8217; Proclamation and More' href='http://carycitizen.com/2018/11/12/harolds-blog-election-day-veterans-proclamation-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Mayor" srcset="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Harold&#8217;s Blog: Election Day, Veterans&#8217; Proclamation and More<span class='news-time'>November 12, 2018 - 1:01 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Canes Can&#8217;t Keep Lead, Lose in SO 4-3' href='http://carycitizen.com/2018/11/12/canes-cant-keep-lead-lose-in-so-4-3/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Carolina Hurricanes" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes Can&#8217;t Keep Lead, Lose in SO 4-3<span class='news-time'>November 12, 2018 - 9:30 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Applause! Cary Youth Theatre Celebrates 20th Season' href='http://carycitizen.com/2018/11/09/applause-cary-youth-theatre-celebrates-20th-season/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Applause! Cary Youth Theatre" srcset="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Applause! Cary Youth Theatre Celebrates 20th Season<span class='news-time'>November 9, 2018 - 12:56 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-13" class="widget clearfix newsbox"><h3 class="widgettitle">Arts</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Applause! Cary Youth Theatre Celebrates 20th Season' href='http://carycitizen.com/2018/11/09/applause-cary-youth-theatre-celebrates-20th-season/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Applause! Cary Youth Theatre" srcset="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Applause! Cary Youth Theatre Celebrates 20th Season<span class='news-time'>November 9, 2018 - 12:56 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Popular &#8220;White Christmas Sing-a-Long&#8221; Unable to Play at Cary Theater This Year' href='http://carycitizen.com/2018/11/09/popular-white-christmas-sing-a-long-unable-to-play-at-cary-theater-this-year/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Theater" srcset="http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Popular &#8220;White Christmas Sing-a-Long&#8221; Unable to Play at Cary Theater This Year<span class='news-time'>November 9, 2018 - 9:30 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Winter and Holiday Events for Cary 2018' href='http://carycitizen.com/2018/11/08/winter-and-holiday-events-for-cary-2018/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Winter and Holiday Events for Cary 2018<span class='news-time'>November 8, 2018 - 1:45 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-12" class="widget clearfix newsbox"><h3 class="widgettitle">Business</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Popular &#8220;White Christmas Sing-a-Long&#8221; Unable to Play at Cary Theater This Year' href='http://carycitizen.com/2018/11/09/popular-white-christmas-sing-a-long-unable-to-play-at-cary-theater-this-year/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Theater" srcset="http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/CofoundersLab2-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Popular &#8220;White Christmas Sing-a-Long&#8221; Unable to Play at Cary Theater This Year<span class='news-time'>November 9, 2018 - 9:30 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='At Economic Talk, Cary and NC Continue Grow as Types of Jobs Continue to Shrink' href='http://carycitizen.com/2018/11/08/at-economic-talk-cary-and-nc-continue-grow-as-types-of-jobs-continue-to-shrink/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/cary-chamber-ted-abernathy-7500-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>At Economic Talk, Cary and NC Continue Grow as Types of Jobs Continue to Shrink<span class='news-time'>November 8, 2018 - 1:01 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Amazon Splits HQ2 Pick Into Two Sites, and We&#8217;re Neither Of Them' href='http://carycitizen.com/2018/11/06/amazon-splits-hq2-pick-into-two-sites-and-were-neither-of-them/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Downtown Raleigh" srcset="http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/01/DT-Raleigh-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Amazon Splits HQ2 Pick Into Two Sites, and We&#8217;re Neither Of Them<span class='news-time'>November 6, 2018 - 1:01 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-19" class="widget clearfix newsbox"><h3 class="widgettitle">Cary Guides</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Winter and Holiday Events for Cary 2018' href='http://carycitizen.com/2018/11/08/winter-and-holiday-events-for-cary-2018/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Winter and Holiday Events for Cary 2018<span class='news-time'>November 8, 2018 - 1:45 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Guide to Beer In and Around Cary' href='http://carycitizen.com/2018/10/11/guide-to-beer-in-and-around-cary/'><span class='news-thumb '><img width="36" height="24" src="http://carycitizen.com/wp-content/uploads/2012/06/beer-guide-to-hops.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2012/06/beer-guide-to-hops.jpg 600w, http://carycitizen.com/wp-content/uploads/2012/06/beer-guide-to-hops-300x199.jpg 300w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Guide to Beer In and Around Cary<span class='news-time'>October 11, 2018 - 9:11 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Guide to Cary Fall 2018 Events' href='http://carycitizen.com/2018/08/09/guide-to-cary-fall-2018-events/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/08/pumpkins-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Guide to Cary Fall 2018 Events<span class='news-time'>August 9, 2018 - 1:03 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="nav_menu-8" class="widget clearfix widget_nav_menu"><h3 class="widgettitle">Directories</h3><div class="menu-maps-directories-container"><ul id="menu-maps-directories" class="menu"><li id="menu-item-75939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75939"><a href="http://carycitizen.com/maps-guides/downtown-dining/">Downtown Dining Map</a></li>
<li id="menu-item-77633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77633"><a href="http://carycitizen.com/maps-guides/supermarkets/">Supermarkets Map</a></li>
<li id="menu-item-75940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75940"><a href="http://carycitizen.com/maps-guides/cary-parks/">Cary Parks Map</a></li>
<li id="menu-item-75941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75941"><a href="http://carycitizen.com/maps-guides/cary-nc-non-profits/">Cary NC Non-Profits Directory</a></li>
<li id="menu-item-75936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75936"><a href="http://carycitizen.com/maps-guides/worship-page/">Worship Directory</a></li>
</ul></div><span class="seperator extralight-border"></span></section><section id="newsbox-14" class="widget clearfix newsbox"><h3 class="widgettitle">Education</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Applause! Cary Youth Theatre Celebrates 20th Season' href='http://carycitizen.com/2018/11/09/applause-cary-youth-theatre-celebrates-20th-season/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Applause! Cary Youth Theatre" srcset="http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/CaryYouthTheatre5-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Applause! Cary Youth Theatre Celebrates 20th Season<span class='news-time'>November 9, 2018 - 12:56 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Cary Band Day Returns for 60th Year' href='http://carycitizen.com/2018/11/02/cary-band-day-returns-for-60th-year/'><span class='news-thumb '><img width="36" height="21" src="http://carycitizen.com/wp-content/uploads/2014/10/DSC_3727-L.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2014/10/DSC_3727-L.jpg 600w, http://carycitizen.com/wp-content/uploads/2014/10/DSC_3727-L-300x175.jpg 300w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Cary Band Day Returns for 60th Year<span class='news-time'>November 2, 2018 - 9:31 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Education: Bill Fletcher October 2018 Newsletter' href='http://carycitizen.com/2018/10/31/education-bill-fletcher-october-2018-newsletter/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Wake County Public School System" srcset="http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2017/05/Fletcher-May2017-2-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Education: Bill Fletcher October 2018 Newsletter<span class='news-time'>October 31, 2018 - 2:37 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-17" class="widget clearfix newsbox"><h3 class="widgettitle">Events</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Weekend Events: Holiday Events, Turkey Day Jam and More' href='http://carycitizen.com/2018/11/14/weekend-events-holiday-events-turkey-day-jam-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2017/11/HolidayGuide-2017-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Weekend Events: Holiday Events, Turkey Day Jam and More<span class='news-time'>November 14, 2018 - 9:29 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Winter and Holiday Events for Cary 2018' href='http://carycitizen.com/2018/11/08/winter-and-holiday-events-for-cary-2018/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2016/12/lantern-fest-2016-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Winter and Holiday Events for Cary 2018<span class='news-time'>November 8, 2018 - 1:45 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Weekend Events: Diamante Awards, Food and Flea and More' href='http://carycitizen.com/2018/11/07/weekend-events-diamante-awards-food-and-flea-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary" srcset="http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/10/clock-downtown-cary-7083-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Weekend Events: Diamante Awards, Food and Flea and More<span class='news-time'>November 7, 2018 - 9:32 AM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-16" class="widget clearfix newsbox"><h3 class="widgettitle">Food</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Cary Student Wins Two Cooking Competitions at 2018 State Fair' href='http://carycitizen.com/2018/10/30/cary-student-wins-two-cooking-competitions-at-2018-state-fair/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="NC State Fair" srcset="http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/10/StateFairContest2018-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Cary Student Wins Two Cooking Competitions at 2018 State Fair<span class='news-time'>October 30, 2018 - 1:02 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Honeysuckle Gelato Set to Open in Fenton Development' href='http://carycitizen.com/2018/10/23/honeysuckle-gelato-set-to-open-in-fenton-development/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Fenton" srcset="http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/10/HoneysuckleGelato2-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Honeysuckle Gelato Set to Open in Fenton Development<span class='news-time'>October 23, 2018 - 1:02 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Triangle Oktoberfest Brings German Food, Music and Beer for a Good Cause' href='http://carycitizen.com/2018/10/18/triangle-oktoberfest-brings-german-food-music-and-beer-for-a-good-cause/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/10/steinhoisting-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Triangle Oktoberfest Brings German Food, Music and Beer for a Good Cause<span class='news-time'>October 18, 2018 - 1:09 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-15" class="widget clearfix newsbox"><h3 class="widgettitle">Opinion</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Harold&#8217;s Blog: Election Day, Veterans&#8217; Proclamation and More' href='http://carycitizen.com/2018/11/12/harolds-blog-election-day-veterans-proclamation-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Mayor" srcset="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov12-6-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Harold&#8217;s Blog: Election Day, Veterans&#8217; Proclamation and More<span class='news-time'>November 12, 2018 - 1:01 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Samaritan&#8217;s Corner: The Easel of Jesus' href='http://carycitizen.com/2018/11/08/samaritans-corner-the-easel-of-jesus/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Police" srcset="http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/SamaritanCorner-Nov7-3-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Samaritan&#8217;s Corner: The Easel of Jesus<span class='news-time'>November 8, 2018 - 10:24 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Harold&#8217;s Blog: The Hive, Cary Band Day and More' href='http://carycitizen.com/2018/11/05/harolds-blog-the-hive-cary-band-day-and-more/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Cary Mayor" srcset="http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/HaroldBlog-Nov5-10-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Harold&#8217;s Blog: The Hive, Cary Band Day and More<span class='news-time'>November 5, 2018 - 1:02 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="newsbox-18" class="widget clearfix newsbox"><h3 class="widgettitle">Sports</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Canes Have Comeback 3-2 OT Win Against Ward and Blackhawks' href='http://carycitizen.com/2018/11/13/canes-have-comeback-3-2-ot-win-against-ward-and-blackhawks/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Carolina Hurricanes" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov13-2018-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes Have Comeback 3-2 OT Win Against Ward and Blackhawks<span class='news-time'>November 13, 2018 - 9:31 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Canes Can&#8217;t Keep Lead, Lose in SO 4-3' href='http://carycitizen.com/2018/11/12/canes-cant-keep-lead-lose-in-so-4-3/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Carolina Hurricanes" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Canes-Nov12-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes Can&#8217;t Keep Lead, Lose in SO 4-3<span class='news-time'>November 12, 2018 - 9:30 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Canes Fall To Bruins, 3-2' href='http://carycitizen.com/2018/10/31/canes-fall-to-bruins-3-2/'><span class='news-thumb '><img width="36" height="36" src="http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Carolina Hurricanes" srcset="http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/10/Canes-Oct31-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes Fall To Bruins, 3-2<span class='news-time'>October 31, 2018 - 10:30 AM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section></div></aside>

			</div><!--end container-->

		</div><!-- close default .container_wrap element -->


						<div class='container_wrap footer_color' id='footer'>

					<div class='container'>

						<div class='flex_column av_one_third  first el_before_av_one_third'><section id="nav_menu-7" class="widget clearfix widget_nav_menu"><h3 class="widgettitle">About Us</h3><div class="menu-footer-2017-1-container"><ul id="menu-footer-2017-1" class="menu"><li id="menu-item-88906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88906"><a href="http://carycitizen.com/subscribe/">Subscribe</a></li>
<li id="menu-item-88901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88901"><a href="http://carycitizen.com/contributors/">Contributors</a></li>
<li id="menu-item-88903" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88903"><a href="http://carycitizen.com/policies-faqs/comments-policy/">Comments Policy</a></li>
<li id="menu-item-88904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88904"><a href="http://carycitizen.com/policies-faqs/submitting-stories/">Submitting Stories</a></li>
<li id="menu-item-88902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88902"><a href="http://carycitizen.com/policies-faqs/calendar-faq/">Calendar FAQ</a></li>
<li id="menu-item-88905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88905"><a href="http://carycitizen.com/policies-faqs/usage-rights/">Usage &#038; Rights</a></li>
<li id="menu-item-88900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88900"><a href="http://carycitizen.com/contact/">Contact</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_third  el_after_av_one_third  el_before_av_one_third '><section id="nav_menu-11" class="widget clearfix widget_nav_menu"><h3 class="widgettitle">Business Services</h3><div class="menu-footer-2017-2-container"><ul id="menu-footer-2017-2" class="menu"><li id="menu-item-88907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88907"><a href="http://carycitizen.com/advertising/">Advertising</a></li>
<li id="menu-item-90005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90005"><a href="http://carycitizen.com/photography/">Photography</a></li>
<li id="menu-item-89566" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89566"><a href="http://carycitizen.com/websites/">Websites</a></li>
<li id="menu-item-88908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88908"><a href="http://carycitizen.com/business-services/">Business Services</a></li>
</ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_third  el_after_av_one_third  el_before_av_one_third '><section id="search-3" class="widget clearfix widget_search">

<form action="http://carycitizen.com/" id="searchform" method="get" class="">
	<div>
		<input type="submit" value="" id="searchsubmit" class="button avia-font-entypo-fontello" />
		<input type="text" id="s" name="s" value="" placeholder='Search' />
			</div>
</form><span class="seperator extralight-border"></span></section></div>

					</div>


				<!-- ####### END FOOTER CONTAINER ####### -->
				</div>

	


			

			
				<footer class='container_wrap socket_color' id='socket'  role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter" >
                    <div class='container'>

                        <span class='copyright'>©2018 CaryCitizen. All rights reserved. A publication of <a href="http://goodtreecompany.com/" target="_blank">Goodtree & Co, Inc.</a>. </span>

                        <ul class='noLightbox social_bookmarks icon_count_2'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target='_blank' href='https://twitter.com/carycitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_facebook av-social-link-facebook social_icon_2'><a target='_blank' href='https://www.facebook.com/CaryCitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Facebook'><span class='avia_hidden_link_text'>Facebook</span></a></li></ul>
                    </div>

	            <!-- ####### END SOCKET CONTAINER ####### -->
				</footer>


					<!-- end main -->
		</div>
		
		<a class='avia-post-nav avia-post-prev with-image' href='http://carycitizen.com/2018/11/13/the-hive-west-carys-first-town-recreation-facility-now-open/' >    <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span>    <span class='entry-info-wrap'>        <span class='entry-info'>            <span class='entry-title'>The Hive, West Cary&#8217;s First Town Recreation Facility, Now Open</span>            <span class='entry-image'><img width="80" height="80" src="http://carycitizen.com/wp-content/uploads/2018/11/Hive1-80x80.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="The Hive" srcset="http://carycitizen.com/wp-content/uploads/2018/11/Hive1-80x80.jpg 80w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-36x36.jpg 36w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-180x180.jpg 180w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-120x120.jpg 120w, http://carycitizen.com/wp-content/uploads/2018/11/Hive1-450x450.jpg 450w" sizes="(max-width: 80px) 100vw, 80px" /></span>        </span>    </span></a><!-- end wrap_all --></div>

	<div style="display:none">
	</div>

 <script type='text/javascript'>
 /* <![CDATA[ */  
var avia_framework_globals = avia_framework_globals || {};
    avia_framework_globals.frameworkUrl = 'http://carycitizen.com/wp-content/themes/enfold%203.8/framework/';
    avia_framework_globals.installedAt = 'http://carycitizen.com/wp-content/themes/enfold%203.8/';
    avia_framework_globals.ajaxurl = 'http://carycitizen.com/wp-admin/admin-ajax.php';
/* ]]> */ 
</script>
 
 <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201846'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/themes/enfold%203.8/js/avia.js?ver=3'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/themes/enfold%203.8/js/shortcodes.js?ver=3'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/themes/enfold%203.8/js/aviapopup/jquery.magnific-popup.min.js?ver=2'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/comment-reply.min.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=6.7'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-content/plugins/reduce-bounce-rate/js/gajs.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script type='text/javascript' src='http://carycitizen.com/wp-includes/js/wp-embed.min.js?ver=0949d19e92070e135c4a4dc9a61e65ea'></script>
<script async="async" type='text/javascript' src='http://carycitizen.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201846.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.7',blog:'23925539',post:'101428',tz:'-5',srv:'carycitizen.com'} ]);
	_stq.push([ 'clickTrackerInit', '23925539', '101428' ]);
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2187618-17"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2187618-17');
</script><a href='#top' title='Scroll to top' id='scroll-top-link' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Scroll to top</span></a>

<div id="fb-root"></div>
</body>
</html>
