<!DOCTYPE html>
<html lang="en-US" class="html_boxed responsive av-preloader-disabled av-default-lightbox  html_header_top html_logo_center html_bottom_nav_header html_menu_right html_slim html_header_sticky html_header_shrinking html_header_topbar_active html_mobile_menu_tablet html_header_searchicon html_content_align_center html_header_unstick_top_disabled html_header_stretch html_av-submenu-hidden html_av-submenu-display-click html_av-overlay-full html_av-submenu-noclone html_entry_id_110310 av-no-preview html_text_menu_active ">
<head>
<meta charset="UTF-8" />
<meta name="robots" content="index, follow" />


<!-- mobile setting -->
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<!-- Scripts/CSS and wp_head hook -->
<title>Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021 &#8211; CaryCitizen</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="ByZypNwvXRj5Se6JiGq412ICWceAtK32gjW0ClwW5SM" />
<meta name="msvalidate.01" content="0B2C00BBB4F8DDF7CAABD981EF33905A" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Feed" href="https://carycitizen.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Comments Feed" href="https://carycitizen.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen &raquo; Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021 Comments Feed" href="https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/feed/" />

<!-- google webfont font replacement -->

			<script type='text/javascript'>
			if(!document.cookie.match(/aviaPrivacyGoogleWebfontsDisabled/)){
				(function() {
					var f = document.createElement('link');
					
					f.type 	= 'text/css';
					f.rel 	= 'stylesheet';
					f.href 	= '//fonts.googleapis.com/css?family=Heebo:100,400,700';
					f.id 	= 'avia-google-webfont';
					
					document.getElementsByTagName('head')[0].appendChild(f);
				})();
			}
			</script>
			<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;display=fallback&#038;ver=38c0f6522559605df7cbb80a3afb6e3e' type='text/css' media='all' />
<link rel='stylesheet' id='avia-merged-styles-css'  href='https://carycitizen.com/wp-content/uploads/dynamic_avia/avia-merged-styles-a0339f550f19ec44ee9c5db457dc5900.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://carycitizen.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.3' type='text/css' media='all' />
<script type='text/javascript' src='https://carycitizen.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://carycitizen.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=8.2.3'></script>
<script type='text/javascript' src='https://carycitizen.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=8.2.3'></script>
<link rel='https://api.w.org/' href='https://carycitizen.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://carycitizen.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://carycitizen.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Weekend Events: International Festival, Food &#038; Flea, NCFC Season-Opener and More' href='https://carycitizen.com/2020/03/04/weekend-events-international-festival-food-flea-ncfc-season-opener-and-more/' />

<link rel="canonical" href="https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/" />
<link rel='shortlink' href='https://wp.me/p1Co7N-sHc' />
<link rel="alternate" type="application/json+oembed" href="https://carycitizen.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcarycitizen.com%2F2020%2F03%2F05%2Ftaylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://carycitizen.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcarycitizen.com%2F2020%2F03%2F05%2Ftaylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="alternate" type="application/rss+xml" title="CaryCitizen RSS2 Feed" href="https://carycitizen.com/feed/" />
<link rel="pingback" href="https://carycitizen.com/xmlrpc.php" />
<!--[if lt IE 9]><script src="https://carycitizen.com/wp-content/themes/enfold%204.5.2/js/html5shiv.js"></script><![endif]-->
<link rel="icon" href="https://carycitizen.com/wp-content/uploads/2019/05/cc-fav-2019-32.jpg" type="image/x-icon">
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021" />
<meta property="og:url" content="https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/" />
<meta property="og:description" content="Cary, NC — The Taylor Family YMCA off of SW Cary Parkway is raising funds to bring a new permanent, indoor aquatics center to Cary with construction coming in Spring 2020. Dubbed the &#8220;Dick an…" />
<meta property="article:published_time" content="2020-03-05T16:00:01+00:00" />
<meta property="article:modified_time" content="2020-03-05T16:00:01+00:00" />
<meta property="og:site_name" content="CaryCitizen" />
<meta property="og:image" content="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="804" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@CaryCitizen" />
<meta name="twitter:site" content="@CaryCitizen" />
<meta name="twitter:text:title" content="Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021" />
<meta name="twitter:image" content="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- To speed up the rendering and to display the site as fast as possible to the user we include some styles and scripts for above the fold content inline -->
<script type="text/javascript">'use strict';var avia_is_mobile=!1;if(/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)&&'ontouchstart' in document.documentElement){avia_is_mobile=!0;document.documentElement.className+=' avia_mobile '}
else{document.documentElement.className+=' avia_desktop '};document.documentElement.className+=' js_active ';(function(){var e=['-webkit-','-moz-','-ms-',''],n='';for(var t in e){if(e[t]+'transform' in document.documentElement.style){document.documentElement.className+=' avia_transform ';n=e[t]+'transform'};if(e[t]+'perspective' in document.documentElement.style)document.documentElement.className+=' avia_transform3d '};if(typeof document.getElementsByClassName=='function'&&typeof document.documentElement.getBoundingClientRect=='function'&&avia_is_mobile==!1){if(n&&window.innerHeight>0){setTimeout(function(){var e=0,o={},a=0,t=document.getElementsByClassName('av-parallax'),i=window.pageYOffset||document.documentElement.scrollTop;for(e=0;e<t.length;e++){t[e].style.top='0px';o=t[e].getBoundingClientRect();a=Math.ceil((window.innerHeight+i-o.top)*0.3);t[e].style[n]='translate(0px, '+a+'px)';t[e].style.top='auto';t[e].className+=' enabled-parallax '}},50)}}})();</script><style type='text/css'>
@font-face {font-family: 'entypo-fontello'; font-weight: normal; font-style: normal;
src: url('https://carycitizen.com/wp-content/themes/enfold%204.5.2/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot');
src: url('https://carycitizen.com/wp-content/themes/enfold%204.5.2/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?#iefix') format('embedded-opentype'), 
url('https://carycitizen.com/wp-content/themes/enfold%204.5.2/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff') format('woff'), 
url('https://carycitizen.com/wp-content/themes/enfold%204.5.2/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf') format('truetype'), 
url('https://carycitizen.com/wp-content/themes/enfold%204.5.2/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg#entypo-fontello') format('svg');
} #top .avia-font-entypo-fontello, body .avia-font-entypo-fontello, html body [data-av_iconfont='entypo-fontello']:before{ font-family: 'entypo-fontello'; }
</style>

<!--
Debugging Info for Theme support: 

Theme: Enfold
Version: 4.5.2
Installed: enfold 4.5.2
AviaFramework Version: 5.0
AviaBuilder Version: 0.9.5
aviaElementManager Version: 1.0.1
ML:128-PU:65-PLA:10
WP:5.3.2
Compress: CSS:all theme files - JS:all theme files
Updates: disabled
PLAu:9
-->
</head>

<body id="top" class="post-template-default single single-post postid-110310 single-format-standard  rtl_columns boxed heebo arial-websave arial" itemscope="itemscope" itemtype="https://schema.org/WebPage" >

	
	<div id='wrap_all'>

	
<header id='header' class='all_colors header_color light_bg_color  av_header_top av_logo_center av_bottom_nav_header av_menu_right av_slim av_header_sticky av_header_shrinking av_header_stretch av_mobile_menu_tablet av_header_searchicon av_header_unstick_top_disabled av_header_border_disabled'  role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader" >

		<div id='header_meta' class='container_wrap container_wrap_meta  av_icon_active_right av_extra_header_active av_secondary_left av_entry_id_110310'>
		
			      <div class='container'>
			      <ul class='noLightbox social_bookmarks icon_count_3'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target='_blank' href='https://twitter.com/carycitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_facebook av-social-link-facebook social_icon_2'><a target='_blank' href='https://www.facebook.com/CaryCitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Facebook'><span class='avia_hidden_link_text'>Facebook</span></a></li><li class='social_bookmarks_instagram av-social-link-instagram social_icon_3'><a target='_blank' href='https://www.instagram.com/carycitizen/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Instagram'><span class='avia_hidden_link_text'>Instagram</span></a></li></ul><nav class='sub_menu'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><ul id="avia2-menu" class="menu"><li id="menu-item-75925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75925"><a href="https://carycitizen.com/about/">About Us</a></li>
<li id="menu-item-75889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-has-children menu-item-75889"><a href="https://carycitizen.com/policies-faqs/">Policies &#038; FAQs</a>
<ul class="sub-menu">
	<li id="menu-item-75891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75891"><a href="https://carycitizen.com/policies-faqs/submitting-stories/">Submitting Stories</a></li>
	<li id="menu-item-75892" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75892"><a href="https://carycitizen.com/policies-faqs/calendar-faq/">Calendar FAQ</a></li>
	<li id="menu-item-75893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75893"><a href="https://carycitizen.com/policies-faqs/comments-policy/">Comments Policy</a></li>
	<li id="menu-item-75890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75890"><a href="https://carycitizen.com/policies-faqs/usage-rights/">Usage &#038; Rights</a></li>
</ul>
</li>
<li id="menu-item-76065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76065"><a href="https://carycitizen.com/business-services/">Business Services</a></li>
</ul></nav>			      </div>
		</div>

		<div  id='header_main' class='container_wrap container_wrap_logo'>
	
        <div class='container av-logo-container'><div class='inner-container'><span class='logo'><a href='https://carycitizen.com/'><img height='100' width='300' src='http://carycitizen.com/wp-content/uploads/2016/12/cc-logo-450.png' alt='CaryCitizen' /></a></span></div></div><div id='header_main_alternate' class='container_wrap'><div class='container'><nav class='main_menu' data-selectname='Select a page'  role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" ><div class="avia-menu av-main-nav-wrap"><ul id="avia-menu" class="menu av-main-nav"><li id="menu-item-109277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-top-level menu-item-top-level-1"><a href="https://carycitizen.com/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Home</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102279" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-top-level menu-item-top-level-2"><a href="https://carycitizen.com/category/featured/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Latest News</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-102285" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/business/downtown-business/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Downtown</span></a></li>
	<li id="menu-item-102286" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/community/education-community-2/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Education</span></a></li>
	<li id="menu-item-102287" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/community/gardening-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Gardening</span></a></li>
	<li id="menu-item-102282" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/news/government/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Government</span></a></li>
	<li id="menu-item-102288" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/community/history-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">History</span></a></li>
	<li id="menu-item-102291" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/morrisville/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Morrisville</span></a></li>
	<li id="menu-item-102289" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/community/money-matters/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Money Matters</span></a></li>
	<li id="menu-item-102280" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://carycitizen.com/category/news/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">News</span></a></li>
	<li id="menu-item-102290" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/community/parks-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Parks</span></a></li>
	<li id="menu-item-102294" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://carycitizen.com/category/sports/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Sports</span></a></li>
</ul>
</li>
<li id="menu-item-102284" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-top-level menu-item-top-level-3"><a href="https://carycitizen.com/category/business/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Business</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-top-level menu-item-top-level-4"><a href="https://carycitizen.com/category/opinion/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Opinion</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-mega-parent  menu-item-top-level menu-item-top-level-5"><a href="https://carycitizen.com/category/community/events/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Events</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102283" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-top-level menu-item-top-level-6"><a href="https://carycitizen.com/category/arts-community/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Arts</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-mega-parent  menu-item-top-level menu-item-top-level-7"><a href="https://carycitizen.com/category/community/food/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Food</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-102272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-top-level menu-item-top-level-8"><a href="https://carycitizen.com/maps-guides/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Maps</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>


<ul class="sub-menu">
	<li id="menu-item-102276" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://carycitizen.com/maps-guides/downtown-dining/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Downtown Dining</span></a></li>
	<li id="menu-item-102274" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://carycitizen.com/maps-guides/supermarkets/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Supermarkets</span></a></li>
	<li id="menu-item-102277" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://carycitizen.com/maps-guides/cary-parks/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Cary Parks</span></a></li>
</ul>
</li>
<li id="menu-item-102564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-9"><a href="https://carycitizen.com/calendar/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Calendar</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-109105" class="menu-item menu-item-type-custom menu-item-object-custom av-menu-button av-menu-button-colored menu-item-mega-parent  menu-item-top-level menu-item-top-level-10"><a href="https://carycitizen.com/advertising/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Advertise</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-109104" class="menu-item menu-item-type-custom menu-item-object-custom av-menu-button av-menu-button-colored menu-item-top-level menu-item-top-level-11"><a href="http://eepurl.com/SCpj1" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Subscribe</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-search" class="noMobile menu-item menu-item-search-dropdown menu-item-avia-special">
							<a href="?s=" rel="nofollow" data-avia-search-tooltip="

&lt;form action=&quot;https://carycitizen.com/&quot; id=&quot;searchform&quot; method=&quot;get&quot; class=&quot;&quot;&gt;
	&lt;div&gt;
		&lt;input type=&quot;submit&quot; value=&quot;&quot; id=&quot;searchsubmit&quot; class=&quot;button avia-font-entypo-fontello&quot; /&gt;
		&lt;input type=&quot;text&quot; id=&quot;s&quot; name=&quot;s&quot; value=&quot;&quot; placeholder='Search' /&gt;
			&lt;/div&gt;
&lt;/form&gt;" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Search</span></a>
	        		   </li><li class="av-burger-menu-main menu-item-avia-special ">
	        			<a href="#">
							<span class="av-hamburger av-hamburger--spin av-js-hamburger">
					        <span class="av-hamburger-box">
						          <span class="av-hamburger-inner"></span>
						          <strong>Menu</strong>
					        </span>
							</span>
						</a>
	        		   </li></ul></div></nav></div> </div> 			
		<!-- end container_wrap-->
		</div>
	
		<div class='header_bg'></div>

<!-- end header -->
</header>
		
	<div id='main' class='all_colors' data-scroll-offset='88'>

	
		<div class='container_wrap container_wrap_first main_color sidebar_right'>

			<div class='container template-blog template-single-blog '>

<!-- Revive Adserver Hosted edition - HEADER - Ad Management Asynchronous JS Tag - Generated with Revive Adserver v4.1.4 -->
				
<div style="padding: 20px 0px 20px 0px;">
	
<ins data-revive-zoneid="702" data-revive-id="727bec5e09208690b050ccfc6a45d384"></ins>
<script async src="//servedby.revive-adserver.net/asyncjs.php"></script>
					
</div> 
				
<!-- END Revive Adserver -->
			 
				
				<main class='content units av-content-small alpha  av-blog-meta-html-info-disabled'  role="main" itemscope="itemscope" itemtype="https://schema.org/Blog" >

                    <article class='post-entry post-entry-type-standard post-entry-110310 post-loop-1 post-parity-odd post-entry-last single-big with-slider post-110310 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured category-news tag-community tag-news tag-recreation'  itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost" ><div class="big-preview single-big"><a href="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-1030x690.jpg" title="Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021"><img width="845" height="321" src="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-845x321.jpg" class="attachment-entry_with_sidebar size-entry_with_sidebar wp-post-image" alt="" /></a></div><div class='blog-meta'></div><div class='entry-content-wrapper clearfix standard-content'><header class="entry-content-header"><h1 class='post-title entry-title'  itemprop="headline" >	<a href='https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/' rel='bookmark' title='Permanent Link: Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021'>Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021			<span class='post-format-icon minor-meta'></span>	</a></h1><span class='post-meta-infos'><time class='date-container minor-meta updated' >March 5, 2020</time><span class='text-sep text-sep-date'>/</span><span class='comment-container minor-meta'><a href="https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/#respond" class="comments-link" >0 Comments</a></span><span class='text-sep text-sep-comment'>/</span><span class="blog-categories minor-meta">in <a href="https://carycitizen.com/category/community/" rel="tag">Community</a>, <a href="https://carycitizen.com/category/featured/" rel="tag">Featured</a>, <a href="https://carycitizen.com/category/news/" rel="tag">News</a> </span><span class="text-sep text-sep-cat">/</span><span class="blog-author minor-meta">by <span class="entry-author-link" ><span class="vcard author"><span class="fn"><a href="https://carycitizen.com/author/kairisa/" title="Posts by Ashley Kairis" rel="author">Ashley Kairis</a></span></span></span></span></span></header><div class="entry-content"  itemprop="text" ><p>Cary, NC — The Taylor Family YMCA off of SW Cary Parkway is raising funds to bring a new permanent, indoor aquatics center to Cary with construction coming in Spring 2020. Dubbed the &#8220;Dick and Jean Ladd Aquatics Center,&#8221; the indoor pool facility is designed with the purpose of giving access and opportunity for the community to swim throughout the year.</p>
<p><span id="more-110310"></span></p>
<h2>Aquatic Center Amenities and Location</h2>
<p>Once Spring 2021 comes around, the new aquatics center will feature:</p>
<ul>
<li>An 8-lane, 25-yard lap pool</li>
<li>A heated family &amp; teaching pool for swim lessons, group aquatics classes and family swim</li>
<li>Two private locker rooms directly off the pool deck</li>
</ul>
<p>The addition of the aquatics center is projected to allow the Y to offer 12,000+ swim lessons.</p>
<p>The Dick and Jean Ladd Aquatics center is set to be constructed on what is now the grassy area between the main fitness center facility and the outdoor pool and pool house. In order to make room for the necessary construction equipment, the playground that is currently between the buildings will be removed, but a new and improved one will be put on site in the future.</p>
<div id="attachment_671" style="width: 1034px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-671" class="wp-image-671 size-large" src="https://carycitizen.news/wp-content/uploads/2020/03/Eric-Lauren-Aquatic-Center-Location-1024x683.jpg" alt="" width="1024" height="683" /><p id="caption-attachment-671" class="wp-caption-text">Associate Branch Executive Lauren Chappell and Aquatics Director Eric Bjorkquist showcase the area that will soon be under construction.</p></div>
<h2>History of the Project</h2>
<p>The project, more than two decades in the making, has been announced to the public twice before but fell through due to a lack of funds and other priorities coming up for the YMCA of the Triangle Association.</p>
<p>&#8220;This time the association has said we&#8217;re doing it, we&#8217;re committed and it&#8217;s time,&#8221; said Lauren Chappell, the Associate Branch Executive for the Taylor Family Y.</p>
<p>Chappell said including Dick Ladd in the name of the facility was a must as he helped get the YMCA started which previously went by the name Cary Family YMCA. Ladd was always vocal and adamant about pushing for the construction of an indoor pool. &#8220;That&#8217;s why it&#8217;s named after him and his wife who have both passed. Their kids are helping to steer this process and the volunteers in the community have made sure their names are present,&#8221; said Chappell.</p>
<h2>More Ways to Serve More People</h2>
<p>Aquatics Director Eric Bjorkquist is a huge driving force behind this project and is quite possibly the most excited person about it.</p>
<blockquote><p>&#8220;The main thing for us is that we&#8217;re looking to serve more people and different people in different ways than we have before. That&#8217;s probably the most exciting part,&#8221; said Bjorkquist.</p></blockquote>
<p>One of the ways the upcoming build will allow the organization to do this is the addition of two private locker rooms. These locker rooms will be a game changer for individual parents who need to keep track of two or more opposite gendered children.</p>
<p>&#8220;It is problematic, and I can&#8217;t tell you how many times I&#8217;ve had to retrieve little boys for their mothers out of the men&#8217;s locker rooms,&#8221; said Bjorkquist.</p>
<p>Additionally, if there is a person with a disability coming to the facility and they have an opposite gendered caregiver with them, the option of smaller, private locker rooms will create better ease of use.</p>
<p>&#8220;This is going to be great and it&#8217;s just one more way that hopefully we can accommodate more people and make them feel comfortable about coming to the pool and can feel good about being here,&#8221; said Bjorkquist. While these private locker rooms are just two little rooms with showers, sinks and toilets, Bjorkquist says they will make a world of difference.</p>
<p>Another part of the community the indoor pool will be able to accommodate better is those in need of water therapy.</p>
<p>&#8220;With a pool that we can keep warmer, we could have water therapy for arthritis, water aerobics for older folks and for people with disabilities which is going to be fantastic,&#8221; said Bjorkquist.</p>
<h2>Strong Demand for Year-Round Pool Space in Cary</h2>
<div id="attachment_672" style="width: 1034px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-672" class="wp-image-672 size-large" src="https://carycitizen.news/wp-content/uploads/2020/03/Taylor-Y-Pool-Diagram-1024x633.png" alt="" width="1024" height="633" /><p id="caption-attachment-672" class="wp-caption-text">A diagram of the Dick and Jean Ladd Aquatics Center slated to open Spring 2021.</p></div>
<p>In the summertime in Cary, there is no shortage of pool space as there are many neighborhood pools operating during that time of the year. The problem arises when those pools shut down and there is a distinct lack of usable water to be used for programs, classes and teams in Cary.</p>
<blockquote><p>&#8220;Right now we are programmed to the max. There is a strong demand in this community for pool space,&#8221; said Bjorkquist. &#8220;That&#8217;s one thing that we are trying to remedy with this.&#8221;</p></blockquote>
<p>Chappell also said there are swim teams still looking for space.</p>
<p>&#8220;It&#8217;s lap swimmers that have a high demand and we&#8217;re not able to serve our own members the way we would like to. So, with this, we&#8217;ll be able to open it up for our members but also other communities as well&#8221; said Chappell.</p>
<p>The Y&#8217;s own year-round swim team could be expanded tremendously according to Bjorkquist. There are also high school swim teams in the area that have a need for space.</p>
<p>&#8220;I don&#8217;t know that this will allow us to afford more space for them, but there is that potential there,&#8221; said Bjorkquist.</p>
<h2>Bursting the &#8220;Bubble&#8221;</h2>
<p>Since the 1990s at the Taylor Y, the organization has invested in installing a large, insulated &#8220;bubble&#8221; around and above its outdoor pool to allow members to swim during the fall and winter. With the opening of the aquatics center in Spring 2021, the bubble and the stresses that come with it&#8217;s put up and take down will be no more.</p>
<p>&#8220;We have the bubble up now and buying the bubble has served us very well, so we&#8217;re good but the bubble is coming to the end of its life and we&#8217;re looking to the future for something that&#8217;s more sustainable and can accommodate more people and in different ways than can right now,&#8221; said Bjorkquist.</p>
<p>From the week after Labor Day to the last week of April, the bubble stands tall, but the installation and takedown are usually a 3-4 day process — and not inexpensive ones.</p>
<p>&#8220;We spend about $26,000 for insulation removal every year,&#8221; said Bjorkquist. &#8220;Putting it up is a bit more intensive because the Town of Cary permits it and inspects it like an actual building, so any changes to the building code have to be reflected in the way we put it up.&#8221;</p>
<p>While Bjorkquist has always been happy the Town of Cary&#8217;s help to keep the bubble up to code, the new facility means no longer needing to go through an annual inspection process.</p>
<h2>Community Needed to Raise Final Funds</h2>
<p>The total cost for the 10,000 square foot aquatics center addition is just over $5 million dollars. Of that amount, 3.1 million has been raised through fundraising efforts in the past. Through the Y&#8217;s Capital Fundraising Campaign launched in January 2020, the organization hopes to raise an additional $500,000 in community support.</p>
<p>&#8220;Beyond the money in hand and the $500,000, the remainder of the project will be financed with debt taken on by the association,&#8221; said Bjorkquist.</p>
<p>The organization received a challenge gift of $150,000 and whatever amount is raised by the community, up to $150,000, they will match it.</p>
<p>&#8220;So as long as we reach $150,000, we&#8217;ll just have another $200,000 to raise. In our last update to our members, we had raised $101,000, so with the match, that&#8217;s $202,000 with just under to $300,000 to go,&#8221; said Chappell.</p>
<p>All donors will be recognized with a named &#8220;bubble&#8221; sticker added to the temporary display in the Taylor Y lobby. Donors giving $1,000 or more will be recognized on a permanent display inside the new facility once the project is complete. Gifts of $1,000 or more can be paid over any length of time up to five years.</p>
<h2>Donate</h2>
<p>Community supporters can <a href="https://www.ymcatriangleregister.org/personifyebusiness/default.aspx?TabID=725&amp;PledgeProductId=125322&amp;CashProductId=125313&amp;_ga=2.134586482.2022465257.1583354054-225985680.1583262157" target="_blank" rel="noopener noreferrer">donate to the project&#8217;s Capital Campaign</a> or find <a href="https://www.ymcatriangle.org/blog/taylor-y-aquatics-center" target="_blank" rel="noopener noreferrer">more information</a> on the Taylor Family YMCA website. For any further information or questions, contact Eric Bjorkquist, 919-653-2378 or <a href="mailto:Eric.Bjorkquist@YMCATriangle.org">Eric.Bjorkquist@YMCATriangle.<wbr />org</a>.</p>
<p>According to Bjorkquist, &#8220;Your investment will guarantee more space for families to play, for senior citizens to stay active, for children to compete or just make a big splash.&#8221;</p>
<hr />
<p><em>Story and photos by <a href="http://carycitizen.com/author/kairisa/">Ashley Kairis</a>. Pool Diagram courtesy of Eric Bjorkquist.</em></p>
</div><footer class="entry-footer"><span class="blog-tags minor-meta"><strong>Tags:</strong><span> <a href="https://carycitizen.com/tag/community/" rel="tag">Community</a>, <a href="https://carycitizen.com/tag/news/" rel="tag">news</a>, <a href="https://carycitizen.com/tag/recreation/" rel="tag">recreation</a></span></span></footer><div class='post_delimiter'></div></div><div class='post_author_timeline'></div><span class='hidden'>
			<span class='av-structured-data'  itemprop="ImageObject" itemscope="itemscope" itemtype="https://schema.org/ImageObject"  itemprop='image'>
					   <span itemprop='url' >https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool.jpg</span>
					   <span itemprop='height' >804</span>
					   <span itemprop='width' >1200</span>
				  </span><span class='av-structured-data'  itemprop="publisher" itemtype="https://schema.org/Organization" itemscope="itemscope" >
				<span itemprop='name'>Ashley Kairis</span>
				<span itemprop='logo' itemscope itemtype='https://schema.org/ImageObject'>
				   <span itemprop='url'>http://carycitizen.com/wp-content/uploads/2016/12/cc-logo-450.png</span>
				 </span>
			  </span><span class='av-structured-data'  itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person" ><span itemprop='name'>Ashley Kairis</span></span><span class='av-structured-data'  itemprop="datePublished" datetime="2020-03-05T11:00:01-05:00" >2020-03-05 11:00:01</span><span class='av-structured-data'  itemprop="dateModified" itemtype="https://schema.org/dateModified" >2020-03-05 11:00:01</span><span class='av-structured-data'  itemprop="mainEntityOfPage" itemtype="https://schema.org/mainEntityOfPage" ><span itemprop='name'>Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021</span></span></span></article><div class='single-big'></div>


	        	
	        	
<div class='comment-entry post-entry'>

<div class='comment_meta_container'>
			
			<div class='side-container-comment'>
	        		
	        		<div class='side-container-comment-inner'>
	        				        			
	        			<span class='comment-count'>0</span>
   						<span class='comment-text'>replies</span>
   						<span class='center-border center-border-left'></span>
   						<span class='center-border center-border-right'></span>
   						
	        		</div>
	        		
	        	</div>
			
			</div>

<div class='comment_container'><h3 class='miniheading'>Leave a Reply</h3><span class='minitext'>Want to join the discussion? <br/>Feel free to contribute!</span>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://carycitizen.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='110310' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5bd35b33bb" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="173"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
				<!--end content-->
				</main>

				<aside class='sidebar sidebar_right  smartphones_sidebar_active alpha units'  role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar" ><div class='inner_sidebar extralight-border'><section id="custom_html-5" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><!-- Revive Adserver Hosted edition - Ad Management Asynchronous JS Tag - Generated with Revive Adserver v4.1.4 -->
<ins data-revive-zoneid="704" data-revive-id="727bec5e09208690b050ccfc6a45d384"></ins>
<script async src="//servedby.revive-adserver.net/asyncjs.php"></script></div><span class="seperator extralight-border"></span></section><section id="newsbox-23" class="widget clearfix newsbox"><h3 class="widgettitle">Latest Stories</h3><ul class="news-wrap image_size_widget"><li class="news-content post-format-standard"><a class='news-link' title='Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021' href='https://carycitizen.com/2020/03/05/taylor-family-ymca-aims-to-open-indoor-aquatic-center-in-spring-2021/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/03/Eric-Lauren-Taylor-Y-Pool-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Taylor Family YMCA Aims to Open Indoor Aquatic Center in Spring 2021<span class='news-time'>March 5, 2020 - 11:00 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Weekend Events: International Festival, Food &#038; Flea, NCFC Season-Opener and More' href='https://carycitizen.com/2020/03/04/weekend-events-international-festival-food-flea-ncfc-season-opener-and-more/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Weekend Events: International Festival, Food &#038; Flea, NCFC Season-Opener and More<span class='news-time'>March 4, 2020 - 1:49 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Results of the 2020 Primary Election in Cary, NC' href='https://carycitizen.com/2020/03/04/results-of-the-2020-primary-election-in-cary-nc/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/01/flag-us-nc-cary-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Results of the 2020 Primary Election in Cary, NC<span class='news-time'>March 4, 2020 - 10:06 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Ashley&#8217;s Journal: Demolition of Old Cary Library' href='https://carycitizen.com/2020/03/03/ashleys-journal-demolition-of-old-cary-library/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/03/Old-Library-Demolition-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Ashley&#8217;s Journal: Demolition of Old Cary Library<span class='news-time'>March 3, 2020 - 10:39 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More' href='https://carycitizen.com/2020/03/02/harolds-blog-corona-virus-precautions-old-library-demolition-2020-census-and-more/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-36x36.png" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-36x36.png 36w, https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-80x80.png 80w, https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-180x180.png 180w, https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-120x120.png 120w, https://carycitizen.com/wp-content/uploads/2020/03/Coronavirus-Outbreak-Map-450x450.png 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More<span class='news-time'>March 2, 2020 - 1:26 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Canes’ Mistakes Contribute To 3-2 Loss to Avalanche' href='https://carycitizen.com/2020/03/02/canes-mistakes-contribute-to-3-2-loss-to-avalanche/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/03/Canes-Avs-Featured-e1583166347828-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Canes’ Mistakes Contribute To 3-2 Loss to Avalanche<span class='news-time'>March 2, 2020 - 10:51 AM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='2020 Primary: Early Voting Soon to Close, Election Day is Tuesday' href='https://carycitizen.com/2020/02/28/2020-primary-early-voting-soon-to-close-election-day-is-tuesday/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/02/2020-Primary-Early-Voting-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>2020 Primary: Early Voting Soon to Close, Election Day is Tuesday<span class='news-time'>February 28, 2020 - 2:16 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='Business Bits: Boutique Moves to Mayton Inn, E-Sports Center To Open in Waverly Place and More' href='https://carycitizen.com/2020/02/28/business-bits-boutique-moves-to-mayton-inn-e-sports-center-to-open-in-waverly-place-and-more/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-36x36.jpg" class="attachment-widget size-widget wp-post-image" alt="Downtown Cary" srcset="https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2018/10/mayton-inn-downtown-cary-7064-1-450x450.jpg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>Business Bits: Boutique Moves to Mayton Inn, E-Sports Center To Open in Waverly Place and More<span class='news-time'>February 28, 2020 - 12:33 PM</span></strong></a></li><li class="news-content post-format-standard"><a class='news-link' title='March 2020 Shows at The Cary Theater' href='https://carycitizen.com/2020/02/27/march-2020-shows-at-the-cary-theater/'><span class='news-thumb '><img width="36" height="36" src="https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-36x36.jpeg" class="attachment-widget size-widget wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-36x36.jpeg 36w, https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-80x80.jpeg 80w, https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-180x180.jpeg 180w, https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-120x120.jpeg 120w, https://carycitizen.com/wp-content/uploads/2020/02/Cary-Theater-Snow-450x450.jpeg 450w" sizes="(max-width: 36px) 100vw, 36px" /></span><strong class='news-headline'>March 2020 Shows at The Cary Theater<span class='news-time'>February 27, 2020 - 3:29 PM</span></strong></a></li></ul><span class="seperator extralight-border"></span></section><section id="recent-comments-4" class="widget clearfix widget_recent_comments"><h3 class="widgettitle">Latest Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Curtis R Leary</span> on <a href="https://carycitizen.com/2020/03/04/results-of-the-2020-primary-election-in-cary-nc/#comment-44455">Results of the 2020 Primary Election in Cary, NC</a></li><li class="recentcomments"><span class="comment-author-link">Nancy</span> on <a href="https://carycitizen.com/2020/03/02/harolds-blog-corona-virus-precautions-old-library-demolition-2020-census-and-more/#comment-44453">Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More</a></li><li class="recentcomments"><span class="comment-author-link">Nancy</span> on <a href="https://carycitizen.com/2020/03/04/weekend-events-international-festival-food-flea-ncfc-season-opener-and-more/#comment-44452">Weekend Events: International Festival, Food &#038; Flea, NCFC Season-Opener and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary Brown</span> on <a href="https://carycitizen.com/2020/03/03/ashleys-journal-demolition-of-old-cary-library/#comment-44451">Ashley&#8217;s Journal: Demolition of Old Cary Library</a></li><li class="recentcomments"><span class="comment-author-link">Terry Graham</span> on <a href="https://carycitizen.com/2020/03/03/ashleys-journal-demolition-of-old-cary-library/#comment-44450">Ashley&#8217;s Journal: Demolition of Old Cary Library</a></li><li class="recentcomments"><span class="comment-author-link">Barry Shafer</span> on <a href="https://carycitizen.com/2020/03/02/canes-mistakes-contribute-to-3-2-loss-to-avalanche/#comment-44446">Canes’ Mistakes Contribute To 3-2 Loss to Avalanche</a></li><li class="recentcomments"><span class="comment-author-link">Brent</span> on <a href="https://carycitizen.com/2020/03/02/harolds-blog-corona-virus-precautions-old-library-demolition-2020-census-and-more/#comment-44444">Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More</a></li><li class="recentcomments"><span class="comment-author-link">Len Nieman</span> on <a href="https://carycitizen.com/2020/03/02/harolds-blog-corona-virus-precautions-old-library-demolition-2020-census-and-more/#comment-44443">Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary Brown</span> on <a href="https://carycitizen.com/2020/03/02/harolds-blog-corona-virus-precautions-old-library-demolition-2020-census-and-more/#comment-44441">Harold&#8217;s Blog: Corona Virus Precautions, Old Library Demolition, 2020 Census and More</a></li><li class="recentcomments"><span class="comment-author-link">Gary Brown</span> on <a href="https://carycitizen.com/2020/02/28/2020-primary-early-voting-soon-to-close-election-day-is-tuesday/#comment-44440">2020 Primary: Early Voting Soon to Close, Election Day is Tuesday</a></li><li class="recentcomments"><span class="comment-author-link">Brent</span> on <a href="https://carycitizen.com/2020/02/28/2020-primary-early-voting-soon-to-close-election-day-is-tuesday/#comment-44438">2020 Primary: Early Voting Soon to Close, Election Day is Tuesday</a></li><li class="recentcomments"><span class="comment-author-link">Brent</span> on <a href="https://carycitizen.com/2020/02/28/2020-primary-early-voting-soon-to-close-election-day-is-tuesday/#comment-44437">2020 Primary: Early Voting Soon to Close, Election Day is Tuesday</a></li></ul><span class="seperator extralight-border"></span></section></div></aside>

			</div><!--end container-->

		</div><!-- close default .container_wrap element -->


		


			

			
				<footer class='container_wrap socket_color' id='socket'  role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter" >
                    <div class='container'>

                        <span class='copyright'>©2020 CaryCitizen. All rights reserved. A publication of <a href="http://Goodtree.Studio" target="_blank">Goodtree.Studio</a> </span>

                        <ul class='noLightbox social_bookmarks icon_count_3'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target='_blank' href='https://twitter.com/carycitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_facebook av-social-link-facebook social_icon_2'><a target='_blank' href='https://www.facebook.com/CaryCitizen' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Facebook'><span class='avia_hidden_link_text'>Facebook</span></a></li><li class='social_bookmarks_instagram av-social-link-instagram social_icon_3'><a target='_blank' href='https://www.instagram.com/carycitizen/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Instagram'><span class='avia_hidden_link_text'>Instagram</span></a></li></ul>
                    </div>

	            <!-- ####### END SOCKET CONTAINER ####### -->
				</footer>


					<!-- end main -->
		</div>
		
		<a class='avia-post-nav avia-post-prev with-image' href='https://carycitizen.com/2020/03/04/weekend-events-international-festival-food-flea-ncfc-season-opener-and-more/' >    <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span>    <span class='entry-info-wrap'>        <span class='entry-info'>            <span class='entry-title'>Weekend Events: International Festival, Food &#038; Flea, NCFC Season-Opener...</span>            <span class='entry-image'><img width="80" height="80" src="https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-80x80.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-80x80.jpg 80w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-36x36.jpg 36w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-180x180.jpg 180w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-120x120.jpg 120w, https://carycitizen.com/wp-content/uploads/2020/03/Weekend-Events-Food-Flea-450x450.jpg 450w" sizes="(max-width: 80px) 100vw, 80px" /></span>        </span>    </span></a><!-- end wrap_all --></div>

<a href='#top' title='Scroll to top' id='scroll-top-link' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Scroll to top</span></a>

<div id="fb-root"></div>

	<div style="display:none">
	</div>

 <script type='text/javascript'>
 /* <![CDATA[ */  
var avia_framework_globals = avia_framework_globals || {};
    avia_framework_globals.frameworkUrl = 'https://carycitizen.com/wp-content/themes/enfold%204.5.2/framework/';
    avia_framework_globals.installedAt = 'https://carycitizen.com/wp-content/themes/enfold%204.5.2/';
    avia_framework_globals.ajaxurl = 'https://carycitizen.com/wp-admin/admin-ajax.php';
/* ]]> */ 
</script>
 
 <script type='text/javascript' src='https://carycitizen.com/wp-includes/js/comment-reply.min.js?ver=38c0f6522559605df7cbb80a3afb6e3e'></script>
<script type='text/javascript' src='https://carycitizen.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=8.2.3'></script>
<script type='text/javascript' src='https://carycitizen.com/wp-includes/js/wp-embed.min.js?ver=38c0f6522559605df7cbb80a3afb6e3e'></script>
<script async="async" type='text/javascript' src='https://carycitizen.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://carycitizen.com/wp-content/uploads/dynamic_avia/avia-footer-scripts-9edb0ef30ee18ebef9d2760764e0e5b0.js'></script>

			<script>
			if(document.cookie.match(/aviaPrivacyGoogleTrackingDisabled/)){ window['ga-disable-UA-2187618-17'] = true; }
			</script><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2187618-17"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2187618-17');
</script><script type='text/javascript' src='https://stats.wp.com/e-202010.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.3',blog:'23925539',post:'110310',tz:'-5',srv:'carycitizen.com'} ]);
	_stq.push([ 'clickTrackerInit', '23925539', '110310' ]);
</script>
</body>
</html>
